Microsoft Exchange - Managed Services
Incident Report for Compass
Resolved
Our teams report the earlier issues with email being rejected, has been solved. Some customers using Google services may still be required to add or update their SPF records.
Posted Mar 09, 2023 - 10:30 NZDT
Update
We have implemented a "work-around" to bypass the blacklisting of our email servers. This should mean that all mail should now be delivered without being bounced or blocked.
Posted Mar 08, 2023 - 14:54 NZDT
Update
We are continuing to monitor for any further issues.
Posted Mar 08, 2023 - 14:53 NZDT
Update
There are still a few blacklist sites that have our mail servers listed after one of our customers email accounts was compromised and used to send out spam. We are still working with the providers to have our mail servers delisted.
Posted Mar 08, 2023 - 11:26 NZDT
Update
We are still receiving messages that some people are getting some undeliverable email messages. This should only be to a few destinations that use one of 7 blacklist services. We expect this to be cleared in the next 12-18 hours for all users.
Posted Mar 07, 2023 - 18:30 NZDT
Monitoring
The earlier email issue has been resolved. Staff worked into the evening to remedy the "bad reputation" issue, and get our mail servers delisted from many "remote blocking list." Some residue issues may be present over the next 48 hours as services stabilize.
Posted Mar 07, 2023 - 13:42 NZDT
Identified
Some customers may be seeing a "blocked sender" or "bad reputation" error message. We have identified the issue and are actively working to resolve it ASAP.
Posted Mar 06, 2023 - 18:16 NZDT
This incident affected: Managed Services (Email (Exchange)).