Mail services have been fully restored. Customers should now be able to access webmail and send and receive emails as normal.
We apologise for the disruption and thank you for your patience.
Posted May 25, 2026 - 17:43 NZST
Update
Mail services have been fully restored. Customers should now be able to access webmail and send and receive emails as normal.
Our team will continue to monitor services over the coming hours to ensure full stability.
What was affected:
Webmail – customers were unable to access the webmail portal POP & IMAP – sending and receiving emails was impacted
We apologise for the disruption and thank you for your patience.
Posted May 25, 2026 - 16:45 NZST
Monitoring
Mail services are partially restored. Some customers may still be experiencing issues with webmail access and email sending and receiving. Our team is actively monitoring the situation.
What's affected:
Webmail – access may still be intermittent for some customers POP & IMAP – email sending and receiving may still be impacted for some customers
Posted May 25, 2026 - 16:14 NZST
Update
We are continuing to investigate this issue.
Posted May 25, 2026 - 15:28 NZST
Investigating
We're aware that customers are currently experiencing issues with Compass mail services. Our team is actively investigating and will provide an update as soon as possible.
What's affected:
Webmail client login – customers are unable to access the webmail portal Mail server – sending and receiving emails may be impacted
We apologise for the inconvenience and thank you for your patience.
Posted May 25, 2026 - 15:02 NZST
This incident affected: Managed Services (Email (Exchange), Email (POP/IMAP)).