Compass Call Centre Degraded Voice Quality
Incident Report for Compass
Resolved
This incident has been resolved.
Posted Mar 27, 2023 - 17:17 NZDT
Identified
Customers calling 0800 640 840 are expected to hear moderate to severe call quality. Technicians are working on a resolution at present but we ask that all non-urgent calls to Compass Customer Care be deferred until Monday or later in the week if at all possible, to alleviate overload. Please also remember that Webchat is available at www.compass.net.nz during normal operating hours.

Requests and inquiries of a non-urgent nature can be attended to be emailing customersupport@compass.net.nz. We will endeavor to respond to your inquiry within 3 business days.
Posted Mar 25, 2023 - 20:35 NZDT
This incident affected: Voice.