COVID Outbreak - Email instead of calling
Incident Report for Compass
Resolved
This incident has been resolved.
Posted May 23, 2023 - 18:25 NZST
Identified
Just like the rest of the world, our Compass team is also being affected by the Omicron situation. This may result in extended wait times for customer service. The most efficient way to reach us at this time is through email (customersupport@compass.net.nz) , and we assure you that we'll respond to your queries as swiftly as we can. Thank you for your understanding and patience!
Posted May 16, 2023 - 09:44 NZST
This incident affected: Voice, Fibre, and ADSL/VDSL.