Compass Customer Care 0800 640 840 Unavailable
Incident Report for Compass
Resolved
This incident has been resolved.
Posted Mar 09, 2023 - 12:15 NZDT
Update
Customer calls are being answered across Residential queues and we are still testing our Business and Self Service channels.
Posted Mar 09, 2023 - 11:00 NZDT
Monitoring
Calls are coming into the Compass 0800 number and being routed appropriately. Calls are now being answered by staff and we continue to monitor and test our new implementation.
Posted Mar 09, 2023 - 10:32 NZDT
Identified
Customers are advised that planned maintenance to upgrade our phone systems has run over time and calls cannot currently be answered. This is a major upgrade designed to improve voice quality, connectivity and clarity.

Updates provided at 15-minute intervals from 10:30 AM NZDST
Posted Mar 09, 2023 - 10:22 NZDT