Call Centre 0800 number down

Incident Report for Compass

Resolved

Our 0800 number is now fully functional. Thank you for your patience!
Posted Jun 07, 2024 - 16:25 NZST

Identified

Our 0800 number appears to have stopped working. Customers can still reach us on 09 200 4361 or via chat at www.compass.net.nz.
Technicians have been alerted to the problem and we expect to have it solved within the hour. Next update at 4 PM.
Posted Jun 07, 2024 - 15:00 NZST