Compass 0800 640 840
Incident Report for Compass
Resolved
This incident has now been resolved.
Posted Jun 30, 2023 - 09:34 NZST
Identified
An issue has been confirmed by our upstream provider and we are working to implement our own interim solution to ensure customer access to Compass Customer Care is restored by 10 AM.
Posted Jun 29, 2023 - 23:11 NZST
Investigating
This number is currently unavailable due to problems with our upstream provider's network. They are currently investigating the issue and we are waiting for an update. Information will be provided as it comes to hand.

Self-service requests can be made through your customer portal at www.compass.net.nz/mycompass or by emailing customersupport@compass.net.nz if you are a residential customer, or businesssupport@compass.net.nz for business inquiries.
Posted Jun 29, 2023 - 17:29 NZST
This incident affected: Voice.