Call Centre 0800 number down

Incident Report for Compass

Resolved

This has now been resolved.
Posted Apr 09, 2025 - 14:20 NZST

Monitoring

This has now been resolved, We will continue to monitor this issue.
Posted Apr 09, 2025 - 12:25 NZST

Update

We are continuing to investigate this issue.

Next update will be at 12:30 PM.
Posted Apr 09, 2025 - 11:31 NZST

Investigating

Our 0800 number appears to have stopped working. Customers can still reach us at customersupport@compass.net.nz and we will answer your inquiries as soon as possible.
Technicians have been alerted to the problem and we expect to have an update at 11:30 AM.
Posted Apr 09, 2025 - 10:57 NZST