Phone Support
Incident Report for Compass
Resolved
Our support phone lines are back up and working.

For the fastest reply contact us via chat at compass.net.nz
Posted Oct 05, 2022 - 18:36 NZDT
Identified
We are investigating an issue that is affecting our phone support lines.

Please contact us via chat in the meantime.
Posted Oct 05, 2022 - 17:57 NZDT